Vendor Service Outage: Spectrum Ethernet Private LAN (Remote Sites)

Incident Report for Washington University - IT

Resolved

Spectrum has resolved the issue with their EP-LAN service, all WashU services are restored.

If you continue to experience further issues, please contact us at 314-933-3333.
Posted Feb 13, 2025 - 07:29 CST

Investigating

WashU IT is aware of a Spectrum issue affecting network and internet access to some WUSM remote clinics. A list of impacted sites is below this message.

WashU IT is working with the vendor (Charter Spectrum) to troubleshoot and resolve the issue.

We appreciate your patience as Spectrum works to restore service.

Impacted sites:
969 N Mason Rd
700 Rosedale Ave
1 Brookings Dr
8 Millstone Campus Dr
1234 S Kingshighway Blvd
5615 Pershing Ave
1410 Tower Grove Ave
4205 Forest Park Ave
714 Gravois Rd
12634 Olive Blvd
1 Progress Point Pkwy
10806 Olive Blvd
1629 A Roy Dr
114 N Taylor Ave
8888 Ladue Rd
8790 Watson Rd
19 Wolf Creek Dr
1660 W Meyer Rd
5232 Oakland Ave
272 Mayfair Plz
22 N Euclid Ave
320 Euclid Ave
11 Garvey Pkwy
12360 MANCHESTER RD
5301 Veterans Memorial Pkwy
3737 N Kingshighway Blvd FL 2
450 N New Ballas Rd
4116 Von Talge Rd
7107 N Lindbergh Blvd
456 N New Ballas Rd
209 First Executive Ave
226 S Woods Mill Rd
4169 Laclede Ave
555 N New Ballas Rd
Posted Feb 12, 2025 - 13:56 CST
This incident affected: Network & Connectivity (Internet, Network Services).