WashU IT Engineers have resolved the issues affecting ServiceNow. The issue with Incident tickets appearing as chats was identified as something affecting one specific team (Radiology Support); the impact of that has been mitigated by temporarily disabling some chat functionality for that group, which will be re-enabled later. The issue of ServiceNow freezing appears to have been temporary and has resolved with no action taken. If you continue to experience further issues, please contact us at 314-933-3333.
We appreciate your patience during this incident.
Posted Jan 14, 2026 - 11:56 CST
Investigating
WashU IT is investigating several reported issues with ServiceNow. Service Desk teams are experiencing frozen screens or Incident tickets incorrectly appearing as chat conversations.
Teams are working to resolve the issue. Please call 314-933-3333 if you have any questions. We appreciate your patience as we work to restore service.
Posted Jan 14, 2026 - 10:32 CST
This incident affected: IT Management (ServiceNow).