Service Outage - Low Severity: Microsoft Office 2016 Applications

Incident Report for Washington University - IT

Resolved

WashU IT Engineers have identified the root cause of the issue affecting Microsoft Office 2016 users. We have confirmed that upgrading to Office 365 is a valid path to resolve the impact. If you continue to experience further issues, please contact us at 314-933-3333.

We appreciate your patience during this incident.
Posted Apr 23, 2025 - 11:43 CDT

Investigating

WashU IT is investigating reports from users who are seeing blank screens or otherwise can't load Microsoft Outlook, Word, etc. The issue appears to be limited to the remaining users who had not already upgraded to Microsoft Office 365 and are still using Office 2016. A root cause has been identified and technical teams are working on determining a fix.

Teams are working to resolve the issue. Please call 314-933-3333 if you have any questions. We appreciate your patience as we work to restore service.
Posted Apr 23, 2025 - 10:28 CDT
This incident affected: Communications & Collaboration (Office 365).