Service Outage (High Severity): BeyondTrust (Bomgar) License Expired

Incident Report for Washington University - IT

Resolved

WashU IT Engineers have applied a new license file from the vendor and have restored access to BeyondTrust. If you continue to experience further issues, please contact us at 314-933-3333.

We appreciate your patience during this incident.
Posted Jun 18, 2026 - 09:38 CDT

Investigating

WashU IT is investigating an issue with the BeyondTrust (Bomgar) remote support tool giving license errors. WashU is in the process of transitioning from an on-premise version of the BeyondTrust client to a cloud hosted version, and the vendor was expected to continue extending our existing license during this period. Technicians can use other methods (Microsoft Teams) as a temporary workaround to support user needs in the interim.

Teams are working to resolve the issue. Please call 314-933-3333 if you have any questions. We appreciate your patience as we work to restore service.
Posted Jun 18, 2026 - 08:52 CDT
This incident affected: IT Management (Software Licensing).