Service Outage: Power Outage Affecting Multiple Sites

Incident Report for Washington University - IT

Resolved

WashU IT Engineers have confirmed that all affected sites had power restored, and network connectivity has been restored to East Building. If you continue to experience further issues, please contact us at 314-933-3333.

We appreciate your patience during this incident.
Posted Jun 24, 2025 - 14:53 CDT

Update

Washington University IT has confirmed that power has been restored to the affected sites. Network technicians are working to restore network connectivity for East Building floor 2 due to some equipment which did not restart successfully when power came back.

Teams are working to resolve the issue. Please call 314-933-3333 if you have any questions. We appreciate your patience as we work to restore service.
Posted Jun 24, 2025 - 12:49 CDT

Identified

Washington University IT has confirmed that all but one affected sites (East Building 2nd Floor) have power restored.

Teams are working to resolve the issue. Please call 314-933-3333 if you have any questions. We appreciate your patience as we work to restore service.
Posted Jun 24, 2025 - 12:15 CDT

Investigating

WashU IT is investigating a power outage affecting multiple sites due to an issue with an Ameren substation:

McMillan
Tab
TabEX
East Imaging
NRB 3+8 Floors
West Building
BioTech

Teams are working to resolve the issue. Please call 314-933-3333 if you have any questions. We appreciate your patience as we work to restore service.
Posted Jun 24, 2025 - 11:55 CDT
This incident affected: Network & Connectivity (Network Services) and Facilities.