BJC Engineers have resolved the issue with Avaya phones in the Department of Surgery. If you continue to experience further issues, please contact us at 314-933-3333.
We appreciate your patience during this incident.
Posted Sep 10, 2026 - 11:33 CDT
Identified
Washington University IT and BJC Telephony have determined that the phones included in this event were disconnected yesterday evening pursuant to a disconnect request. BJC engineers are reconnecting them.
Teams are working to resolve the issue. Please call 314-933-3333 if you have any questions. We appreciate your patience as we work to restore service.
Posted Sep 10, 2026 - 10:04 CDT
Investigating
WashU IT is investigating an issue with Avaya phones in the Department of Surgery.
Teams are working to resolve the issue. Please call 314-933-3333 if you have any questions. We appreciate your patience as we work to restore service.
Posted Sep 10, 2026 - 10:01 CDT
This incident affected: BJC Devices and Services (BJC Telephony and Fax).