BJC IT Engineers have worked with Cisco and have resolved the issue affecting wifi. If you continue to experience further issues, please contact us at 314-933-3333.
We appreciate your patience during this incident.
Posted Feb 03, 2026 - 18:04 CST
Update
BJC has started a P1 call for wireless device connectivity issues at multiple locations. Root cause has been identified and many of the impacted locations are back online. Troubleshooting continues on the remaining ~4 sites which are still experiencing issues.
Teams are working to resolve the issue. Please call 314-933-3333 if you have any questions. We appreciate your patience as we work to restore service.
Posted Feb 03, 2026 - 17:06 CST
Investigating
BJC has started a P1 call for wireless device connectivity issues at multiple locations, including:
PHCPT Sullivan Hospital CAM south county Siteman south county, Ladue for Behavioral Health AMH CSCC - South County Christian IV pumps Barnes Jewish Orthopedic center building behavioral health kingshighway building Medical Group Ladue Rd-Bldg1
Wired devices do not appear to be impacted. WashU SSID's do not appear to be affected.
Teams are working to resolve the issue. Please call 314-933-3333 if you have any questions. We appreciate your patience as we work to restore service.
Posted Feb 03, 2026 - 16:12 CST
This incident affected: BJC Devices and Services (BJC Network Connectivity).