Service Degradation: Archibus
Incident Report for Washington University - IT
Resolved
The process workaround has been provided which has resolved end-user impact.

Engineers will be working with the vendor to resolve the underlying cause in their application.
Posted Apr 26, 2024 - 10:23 CDT
Identified
Washington University IT has identified a UI bug in Archibus that is affecting editing user surveys.

A communication is being sent to users with a workaround and a case has been opened with the vendor.
Posted Apr 26, 2024 - 09:45 CDT
This incident affected: Vendor Service.