BJC Service Outage: Wifi Unavailable at BJH West County

Incident Report for Washington University - IT

Resolved

BJC IT has resolved the issues affecting wifi at BJH West County.

Please call 314-933-3333 if you have any questions.
Posted Jan 08, 2026 - 17:02 CST

Investigating

BJC IT is investigating an issue affecting wifi at Barnes Jewish Hospital West County. Clinicians cannot connect to wireless devices including those used for patient care, e.g. point of care devices, PPID printers, etc.

Teams are working to resolve the issue. Please call 314-933-3333 if you have any questions. We appreciate your patience as we work to restore service.
Posted Jan 08, 2026 - 16:00 CST
This incident affected: BJC Devices and Services (BJC Network Connectivity).