Microsoft has identified and resolved the issue affecting Teams audio. If you continue to experience further issues, please contact us at 314-933-3333.
We appreciate your patience during this incident.
Posted Mar 10, 2026 - 10:46 CDT
Investigating
WashU IT is receiving reports of intermittent audio issues with Microsoft Teams. Microsoft has posted a notification about a service outage on their end. Please see additional details here: https://x.com/MSFT365Status/status/2031384458893361389
"We're investigating an issue in which some Teams users in North America may experience poor audio and video quality. More information may be found in the Microsoft 365 admin center under TM1248186."
Teams are working to resolve the issue. Please call 314-933-3333 if you have any questions. We appreciate your patience as we work to restore service.
Posted Mar 10, 2026 - 10:14 CDT
This incident affected: Communications & Collaboration (Microsoft Teams).