BJC Service Outage: Haiku

Incident Report for Washington University - IT

Resolved

BJC IT Engineers have resolved the issue with Haiku.

If you continue to experience further issues, please contact us at 314-933-3333.

We appreciate your patience during this incident.
Posted Dec 19, 2025 - 10:43 CST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Dec 19, 2025 - 10:32 CST

Investigating

WashU IT is aware an issue with the Haiku app. BJC teams are working to resolve the issue.

Please call 314-933-3333 if you have any questions.

We appreciate your patience as we work to restore service.
Posted Dec 19, 2025 - 08:45 CST
This incident affected: BJC Devices and Services (BJC Clinical Applications).