Service Outage: RMS
Incident Report for Washington University - IT
Resolved
The Vendor has resolved the certificate issue affecting RMS. If you continue to experience further issues, please contact us at 314-933-3333.

We appreciate your patience during this incident.
Posted May 14, 2021 - 10:10 CDT
Identified
Washington University IT has identified a vendor certificate issue with RMS. A workaround may be available by clicking-past the browser security warning or using a different browser (Chrome or Safari). The vendor is working on resolving the issue.

Please call 314-933-3333 if you have any questions. We appreciate your patience as the vendor works to restore service.
Posted May 14, 2021 - 08:51 CDT
This incident affected: Administrative & Enterprise Systems (Research Management System (RMS)).