Service Outage - High Severity: Slate Graduate Record Issue

Incident Report for Washington University - IT

Resolved

WashU IT Engineers have mitigated the incorrect data in Slate. If you continue to experience further issues, please contact us at 314-933-3333.

We appreciate your patience during this incident.
Posted Aug 15, 2025 - 16:48 CDT

Update

WashU IT is investigating an issue with the Slate Graduate Admissions platform. Corrupted records were inadvertently included in a recent data import, causing incorrect user data to be populated in Slate; this primarily impacts Law School records and could also impact several downstream platforms.

Technical teams have completed the first batch of corrections identified this morning. A second round of corrections is in progress to ensure that all affected records are mitigated.

Teams are working to resolve the issue. Please call 314-933-3333 if you have any questions. We appreciate your patience as we work to restore service.
Posted Aug 15, 2025 - 15:20 CDT

Investigating

WashU IT is investigating an issue with the Slate Graduate Admissions platform. Corrupted records were inadvertently included in a recent data import, causing incorrect user data to be populated in Slate; this primarily impacts Law School records and could also impact several downstream platforms. Efforts are in progress to remediate the issue, prioritizing any publicly visible information.

Teams are working to resolve the issue. Please call 314-933-3333 if you have any questions. We appreciate your patience as we work to restore service.
Posted Aug 15, 2025 - 12:17 CDT
This incident affected: University Websites (Externally Hosted Websites).