Service Outage: Microsoft 365 Services

Incident Report for Washington University - IT

Resolved

Microsoft reports that they have resolved the partial Microsoft 365 Services issue and WashU IT has confirmed that services are functioning nominally. If you continue to experience further issues, please contact us at 314-933-3333.

We appreciate your patience during this incident.
Posted Jul 23, 2026 - 14:19 CDT

Update

We are continuing to work on a fix for this issue.
Posted Jul 23, 2026 - 14:16 CDT

Update

Washington University IT has identified a vendor outage to Microsoft 365 services that is affecting many organizations including WashU. Microsoft has acknowledged the problem and has taken steps to reroute network traffic in the US West region. They report services are improving and continue to troubleshoot.

Teams are working to resolve the issue. Please call 314-933-3333 if you have any questions. We appreciate your patience as we work to restore service.
Posted Jul 23, 2026 - 12:26 CDT

Update

Washington University IT has identified a vendor outage to Microsoft 365 services that is affecting many organizations including WashU. Microsoft has confirmed they are aware of the issues

Confirmed Affected Services:
-Whiteboard
-Sharepoint
-Teams Attachments
-One Drive
-One Note
Posted Jul 23, 2026 - 10:22 CDT

Identified

Washington University IT has identified a vendor outage to Microsoft 365 services that is affecting many organizations including WashU. Microsoft Teams, SharePoint, and Whiteboard have been identified as issues.

Microsoft is working to resolve the issue. Please call 314-933-3333 if you have any questions.

We appreciate your patience as Microsoft works to restore service.
Posted Jul 23, 2026 - 10:17 CDT
This incident affected: Communications & Collaboration (Office 365, Microsoft Teams).