Service Outage (Vendor) - High Severity: Box Storage Intermittently Unavailable

Incident Report for Washington University - IT

Resolved

WashU IT has received an update from the Box Storage vendor indicating that they have resolved the issue affecting their services.. If you continue to experience further issues, please contact us at 314-933-3333.

We appreciate your patience during this incident.
Posted Jan 07, 2026 - 20:40 CST

Investigating

WashU IT is aware that the Box Storage vendor is experiencing a service disruption affecting the web client and Box application. Users are reporting intermittent error messages and difficulty connecting to Box Storage.

Please call 314-933-3333 if you have any questions. We appreciate your patience as we work to restore service.
Posted Jan 07, 2026 - 19:45 CST
This incident affected: Communications & Collaboration (Box File Storage System).