WashU IT Engineers have taken steps to prevent additional occurrences of the Citrix icon issue and have provided workaround steps to the Service Desk team. The Major Incident will be concluded.
We appreciate your patience during this incident.
Posted Aug 26, 2026 - 14:49 CDT
Update
WashU IT is investigating reports of issues with the Citrix icon not working or not showing the correct Epic icons once opened. Technical teams have paused deployment of the current Windows version upgrade while the investigation continues.
Teams are working to resolve the issue. Please call 314-933-3333 if you have any questions. We appreciate your patience as we work to restore service.
Posted Aug 26, 2026 - 12:40 CDT
Investigating
WashU IT is investigating reports of issues with the Citrix icon not working or not showing the correct Epic icons once opened. This may be a reoccurrence of issues originally reported on 8/18.
Teams are working to resolve the issue. Please call 314-933-3333 if you have any questions. We appreciate your patience as we work to restore service.
Posted Aug 26, 2026 - 08:57 CDT
This incident affected: Clinical Applications (ECV (Enterprise Client Virtualization)).