WashU IT and BJC Engineers have identified and resolved the issue affecting Epic and other services. If you continue to experience further issues, please contact us at 314-933-3333.
We appreciate your patience during this incident.
Posted Jul 10, 2026 - 16:58 CDT
Update
WashU IT is investigating reports from WashU users experiencing slowness with Epic, Sectra and other applications on the BJC network. Technical teams continue to troubleshoot the issues with Cisco support engineers.
Teams are working to resolve the issue. Please call 314-933-3333 if you have any questions. We appreciate your patience as we work to restore service.
Posted Jul 10, 2026 - 15:31 CDT
Update
WashU IT is investigating reports from WashU users experiencing slowness with Epic, Sectra and other applications on the BJC network. Technical teams continue to troubleshoot the issues and have engaged Cisco technical support for further assistance.
Teams are working to resolve the issue. Please call 314-933-3333 if you have any questions. We appreciate your patience as we work to restore service.
Posted Jul 10, 2026 - 13:46 CDT
Update
WashU IT is investigating reports from WashU users experiencing slowness with Epic, Sectra and other applications on the BJC network. Technical teams from WashU and BJC continue to troubleshoot the issues and coordinate restorative efforts.
Teams are working to resolve the issue. Please call 314-933-3333 if you have any questions. We appreciate your patience as we work to restore service.
Posted Jul 10, 2026 - 12:16 CDT
Investigating
WashU IT is investigating reports from WashU users stating that they are experiencing slow response with Epic and Epic printing, as well as possibly other BJC resources. Remote users are also reporting issues. Technical teams have engaged BJC IT for additional assistance.
Teams are working to resolve the issue. Please call 314-933-3333 if you have any questions. We appreciate your patience as we work to restore service.
Posted Jul 10, 2026 - 10:54 CDT
This incident affected: BJC Devices and Services (BJC Network Connectivity).