Service Outage - High Severity: Continuum.wustl.edu Unavailable (Ophthalmology Image Site)

Incident Report for Washington University - IT

Resolved

WashU IT Engineers have resolved the expired certificate issue with the Continuum website. If you continue to experience further issues, please contact us at 314-933-3333.

We appreciate your patience during this incident.
Posted Mar 23, 2026 - 11:30 CDT

Update

WashU IT continues to investigate the issue with renewing the expired certificate on the Continuum website.

Teams are working to resolve the issue. Please call 314-933-3333 if you have any questions. We appreciate your patience as we work to restore service. [Select components below that are relevantly affected]
Posted Mar 23, 2026 - 10:26 CDT

Investigating

WashU IT is investigating an issue with the Continuum.wustl.edu website. This site is used within Epic for doctors to view Ophthalmology images. An SSL certificate expired for the site and as a result, accessing the site returns a message about the connection not being private. A support ticket has been opened with the SSL certificate provider for assistance on creating a new certificate.

Teams are working to resolve the issue. Please call 314-933-3333 if you have any questions. We appreciate your patience as we work to restore service.
Posted Mar 23, 2026 - 09:20 CDT
This incident affected: Clinical Applications (EPIC, Clinical Websites).