Service Outage (Vendor) - High Severity: Workday Unavailable

Incident Report for Washington University - IT

Resolved

WashU IT Engineers have confirmed that the vendor has resolved the issues affecting Workday and has restored service. If you continue to experience further issues, please contact us at 314-933-3333.

We appreciate your patience during this incident.
Posted Mar 17, 2025 - 15:32 CDT

Identified

WashU IT is investigating reports that users are attempting to log into Workday and are experiencing an error screen stating that Workday is unavailable. The vendor has identified an issue in their infrastructure and is working to resolve the outage.

Teams are working to resolve the issue. Please call 314-933-3333 if you have any questions. We appreciate your patience as we work to restore service.
Posted Mar 17, 2025 - 14:23 CDT

Investigating

WashU IT is investigating reports that users are attempting to log into Workday and are experiencing an error screen stating that Workday is unavailable. Online reports indicate that other customers are experiencing difficulties, suggesting that this is a vendor service outage. A support case will be opened with the vendor.

Teams are working to resolve the issue. Please call 314-933-3333 if you have any questions. We appreciate your patience as we work to restore service.
Posted Mar 17, 2025 - 13:52 CDT
This incident affected: Administrative & Enterprise Systems (Workday).