WashU IT Engineers have received confirmation from the Interfolio vendor that their service issues have been resolved. If you continue to experience further issues, please contact us at 314-933-3333.
We appreciate your patience during this incident.
Posted Jul 02, 2025 - 19:18 CDT
Update
WashU IT is investigating an issue with the vendor service Interfolio, which is used by Med School Faculty for the annual review process. The vendor has made some progress on resolving the service outage, and technical teams continue to work with them on fully restoring service.
Teams are working to resolve the issue. Please call 314-933-3333 if you have any questions. We appreciate your patience as we work to restore service.
Posted Jul 02, 2025 - 09:30 CDT
Investigating
WashU IT is investigating an issue with the vendor service Interfolio, which is used by Med School Faculty for the annual review process. Currently the vendor is experiencing a service outage which is preventing users from uploading documents and potentially accessing other features.
Teams are working to resolve the issue. Please call 314-933-3333 if you have any questions. We appreciate your patience as we work to restore service.