Vendor Service Degradation: Search on Externally Hosted Websites

Incident Report for Washington University - IT

Resolved

This incident has been resolved.
Posted Aug 19, 2025 - 10:47 CDT

Monitoring

The vendor has indicated that the issue has been resolved.

WashU will be testing our environment to validate the fix.
Posted Aug 19, 2025 - 10:30 CDT

Identified

WashU IT is aware of a vendor issue affecting the search capability on the sites below:

Washu.edu
Source.washu.edu
Admissions.washu.edu
Financialaid.washu.edu
Advancement.washu.edu
Alumni.washu.edu
Giving.washu.edu
Olin.washu.edu
Students.washu.edu
Equity.washu.edu
Global.washu.edu

The vendor (Cludo) is working to resolve the issue.
Posted Aug 18, 2025 - 10:45 CDT
This incident affected: University Websites (Externally Hosted Websites).