Service Outage: Microsoft 365 Service Degradation

Incident Report for Washington University - IT

Update

WashU IT is investigating an issue with Microsoft 365. Microsoft's indicates that they have had some success at restoring functionality, particularly to Outlook Online and Teams, but that they are still working to adjust load balancing and fully restore services. Please refer to Microsoft's service status page for additional information: https://status.cloud.microsoft/m365/referrer=serviceStatusRedirect

Teams are working to resolve the issue. Please call 314-933-3333 if you have any questions. We appreciate your patience as we work to restore service.
Posted Jan 22, 2026 - 21:42 CST

Update

WashU IT is investigating an issue with Microsoft 365. Microsoft's latest update indicates that they continue to pursue restorative actions and are monitoring their services to determine further actions. Please refer to Microsoft's service status page for additional information: https://status.cloud.microsoft/m365/referrer=serviceStatusRedirect

Teams are working to resolve the issue. Please call 314-933-3333 if you have any questions. We appreciate your patience as we work to restore service.
Posted Jan 22, 2026 - 19:44 CST

Update

WashU IT is investigating an issue with Microsoft 365. Microsoft's latest update indicates that they have taken some corrective action and are evaluating their services to determine if more action is required. Please refer to Microsoft's service status page for additional information: https://status.cloud.microsoft/m365/referrer=serviceStatusRedirect

Teams are working to resolve the issue. Please call 314-933-3333 if you have any questions. We appreciate your patience as we work to restore service.
Posted Jan 22, 2026 - 16:55 CST

Investigating

WashU IT is investigating an issue with Microsoft 365. Per Microsoft's published information, users may see degraded functionality and intermittent service unavailability in email, Teams, SharePoint Online, OneDrive, and other M365 services.

Teams are working to resolve the issue. Please call 314-933-3333 if you have any questions. We appreciate your patience as we work to restore service.
Posted Jan 22, 2026 - 15:35 CST
This incident affects: Communications & Collaboration (Email, Office 365, Microsoft Teams).