Service Outage - Low Severity: 456 N. New Ballas Network

Incident Report for Washington University - IT

Resolved

WashU IT Engineers identified a problem with the UPS backup at the site and have temporarily bypassed it. Devices at the site has been able to reconnect to wired and wireless network connectivity. Technical teams will repair the UPS and reconnect to it in a scheduled change at a later date. If you continue to experience further issues, please contact us at 314-933-3333.

We appreciate your patience during this incident.
Posted Sep 21, 2026 - 09:10 CDT

Investigating

WashU IT is investigating an issue with Internet, Network and Phones not working at 456 N. New Ballas Rd clinic. Following a power outage, Ameren has restored power to the site, but network services are still unavailable.

Teams are working to resolve the issue. Please call 314-933-3333 if you have any questions. We appreciate your patience as we work to restore service.
Posted Sep 21, 2026 - 08:03 CDT
This incident affected: Facilities - Power, Water, Etc.