Vended Service Outage: Learn at Work

Incident Report for Washington University - IT

Resolved

WashU IT Engineers have resolved the issue.

We appreciate your patience during this incident.
Posted Jun 21, 2025 - 10:29 CDT

Investigating

WashU IT is aware an issue with Learn At Work.

The vendor is working to resolve the issue.
Posted Jun 21, 2025 - 08:19 CDT
This incident affected: Vendor Service.