Vendor Service Outage - MidMark via Epic

Incident Report for Washington University - IT

Resolved

A workaround has been provided to users, this Major Incident has concluded.

BJC is continuing to review root cause with the vendor.

If you continue to experience further issues, please contact us at 314-933-3333.
Posted Jun 19, 2025 - 15:19 CDT

Investigating

WashU IT is aware of an issue affecting MidMark access from within Epic.

MidMark is available to use directly from outside of Epic to access old reads.

BJC is working with the vendor to resolve the issue.
Posted Jun 18, 2025 - 09:20 CDT
This incident affected: Clinical (Vended Applications).