Unplanned Vendor Outage - Bank of America Credit Card Processing
Incident Report for Washington University - IT
Resolved
The Bank of America has resolved the issue with payment processing.

If you continue to experience further issues, please contact us at 314-933-3333.

We appreciate your patience during this incident.
Posted Apr 04, 2024 - 13:08 CDT
Investigating
Bank of America is aware of an issue in their systems impacting credit card and payment processing.

BOA is working with their teams to resolve the issue.
Posted Apr 04, 2024 - 09:13 CDT
This incident affected: Vendor Service.