Investigating Intermittent Service Errors

Incident Report for Washington University - IT

Resolved

This incident has been resolved.
Posted Nov 14, 2025 - 13:50 CST

Update

Teams are continuing to monitor service health.

A lingering issue was identified on the printing systems which has been resolved.
Posted Nov 14, 2025 - 13:01 CST

Investigating

WashU IT has received reports of alerts related to various applications having login errors.

Testing thus far suggests all services are currently working.
Posted Nov 14, 2025 - 11:47 CST
This incident affected: Security (Identity Management System (IDM Wustl Key)).