Vendor Service Outage: Box

Incident Report for Washington University - IT

Resolved

The vendor has resolved the issues with Box.

We appreciate your patience during this incident.
Posted Jun 12, 2025 - 16:52 CDT

Identified

Box is currently experiencing an outage affecting all Box customers. Users may be unable to upload, download, update documents or notes.

Box is aware of the issue and working to resolve it.
Posted Jun 12, 2025 - 13:53 CDT
This incident affected: Communications & Collaboration (Box File Storage System).