Service Outage: WashU Key

Incident Report for Washington University - IT

Resolved

This incident has been resolved.
Posted Dec 02, 2025 - 03:20 CST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Dec 02, 2025 - 02:39 CST

Identified

Washington University IT has identified the issue with WashU Key and is working to implement a fix.

We appreciate your patience as we work to restore service.
Posted Dec 02, 2025 - 02:11 CST

Investigating

WashU IT is investigating an issue with WashU Key.

Teams are working to resolve the issue.

We appreciate your patience as we work to restore service.
Posted Dec 02, 2025 - 01:38 CST
This incident affected: Security (Identity Management System (IDM Wustl Key)).