Spectrum Service Outage @ WUCA Monarch Pediatrics

Incident Report for Washington University - IT

Resolved

WashU has received confirmation that the Spectrum fiber cut has been repaired, and service to the Monarch Pediatrics site has been restored. If you continue to experience further issues, please contact us at 314-933-3333.

We appreciate your patience during this incident.
Posted May 11, 2026 - 20:42 CDT

Investigating

WashU and BJC IT teams are monitoring a Spectrum circuit outage which is affecting network, internet and phone services at WUCA Monarch Pediatrics. BJC IT is working on the option on redirect calls to a mobile phone until the site closes at 4:30pm.

Teams are working to resolve the issue. Please call 314-933-3333 if you have any questions.
Posted May 11, 2026 - 15:44 CDT
This incident affected: Network & Connectivity (Vendor Services (Spectrum, AT&T, etc.)).